Requirements

Browser technical specifications for using this site and our tools

If you find you have difficulties with any of our apps, they might be caused by your browser having problems with a feature that we rely upon. In this case, you might find that a button or menu doesn’t seem to do anything, or not what you expect it to do! To help identify these issues, and to give you the confidence that these apps will work with your devices, we have a testing page that will check your browser to make sure that everything is working correctly.


We support the most recent versions of all major browsers:

As these are client-side web apps, they require Javascript for their operation. If you don’t have Javascript enabled in your browser, you will be able to read all the pages on this site, but not use the apps.

We do not support Internet Explorer or older versions (pre-2017) or the native Android Browser. If you are using an Android tablet or phone, we strongly recommend using Chrome for Android instead.

Some features will not be available on all platforms:


© 2015-2018 educ.io